No motion after race-driver-swap in rfactor2

No motion after race-driver-swap in rfactor2

Postby Rinussie » Fri 18. Apr 2014, 15:08

Hi all,

As a member of RARE Endurance Team I am participating in several endurance races. Most races are demanding several driver swaps and there x-sim plugin has a problem.

When I start as first driver I have al motion activated and my sim and motion works flawlessly. Then I swap with a teammate.
But when I swap back and take over the wheel from a teammate there is no motion. The plugin isn't working anymore.

Strange is that some plugins like pedaloverlay plugin, trackmappro plugin and several other plugins are keep working while others like x-sim plugin, and rFDynHUD plugin and sli plugin stops working.

I contacted ISI about this and I got an answers from them, They say it has to do with a different way of initialization of the plugin when driver swapping.
ISI says it's sure that it's the author of the plugin needs to fix this
The issue cannot be fixed by ISI.

So my question to you is, can you do something about it
It very annoying that the movement of my sim is stopped after I take over the wheel with a driver swap ?

I will be very happy to help and test for a solution with this issue.

With regards
Rinus
Last edited by Rinussie on Fri 18. Apr 2014, 16:16, edited 1 time in total.
User avatar
Rinussie
 
Posts: 8
Joined: Wed 7. Nov 2012, 16:05
Location: Spijkenisse Holland
Has thanked: 1 time
Been thanked: 0 time

Re: No motion after driver swap rfactor2

Postby sirnoname » Fri 18. Apr 2014, 15:26

The rFactor plugin is working without problems.
If you copy parts along two different versions of X-Sim it is not working.
Use the Game Wizard and it will copy the correct plugin to the correct subfolders instead of your copy or swap actions.
If a answer is correct or did help you for a solution, please use the solve button.
User avatar
sirnoname
Site Admin
 
Posts: 1743
Images: 45
Joined: Thu 1. Sep 2011, 22:02
Location: Munich, Germany
Has thanked: 35 times
Been thanked: 122 times

Re: No motion after driver swap rfactor2

Postby Rinussie » Fri 18. Apr 2014, 15:28

The plugin in rfactor and rfactor 2 are working great but not when I make a driver swap, at least not with rFactor2.

I dont have rFactor instaled :o

Oh and I always use the game wizard ;)
User avatar
Rinussie
 
Posts: 8
Joined: Wed 7. Nov 2012, 16:05
Location: Spijkenisse Holland
Has thanked: 1 time
Been thanked: 0 time

Re: No motion after driver swap rfactor2

Postby sirnoname » Fri 18. Apr 2014, 15:45

Driver = software for a hardware in the device manager of windows?
What you do for a driver swap?
If a answer is correct or did help you for a solution, please use the solve button.
User avatar
sirnoname
Site Admin
 
Posts: 1743
Images: 45
Joined: Thu 1. Sep 2011, 22:02
Location: Munich, Germany
Has thanked: 35 times
Been thanked: 122 times

Re: No motion after driver swap rfactor2

Postby Rinussie » Fri 18. Apr 2014, 15:56

With driver I mean racedriver.

I'll try to explain :D

So one race-driver is taking over the race-wheel and rf2 racegame from another race-driver true a race-driver-swap in the game.

One is race-driver is racing in Hamburg and one in New York both with a motion sim, after two hours racing the one in New York takes over the race-wheel and rf2 game true a race-driver-swap from the race-driver in Hamburg.
After the race-driver-swap the motion plugin isn't working anymore.

So that is the problem :?:
User avatar
Rinussie
 
Posts: 8
Joined: Wed 7. Nov 2012, 16:05
Location: Spijkenisse Holland
Has thanked: 1 time
Been thanked: 0 time

Re: No motion after race-driver-swap in rfactor2

Postby sirnoname » Fri 18. Apr 2014, 17:55

Then rFactor2 has a new feature there which is not supported in our plugin.
We trigger on this two api functions:
void ExampleInternalsPlugin::EnterRealtime()
void ExampleInternalsPlugin::ExitRealtime()
ask issi if this is not called while driver shifting.

You can see this on/off flag in the input setup on top of the values, it is the checkbox.
If a answer is correct or did help you for a solution, please use the solve button.
User avatar
sirnoname
Site Admin
 
Posts: 1743
Images: 45
Joined: Thu 1. Sep 2011, 22:02
Location: Munich, Germany
Has thanked: 35 times
Been thanked: 122 times

Re: No motion after race-driver-swap in rfactor2

Postby Rinussie » Fri 18. Apr 2014, 20:53

Race driver swaps are as old as rfactor itself this is not a new feature at all.

I don't think you understand what I mean with the race driver swap story above.

When I drive rFactor 2 alone there's nothing wrong with the x-sim plugin everything works great.

The trouble begins when I take over the game from a teammate, then the plugin isn't triggered for some reason.

Some other plugins from other developers have the same problem and some are not having that problem.

So the plugin developers with the problem must be doing something wrong compared to the plugins that are still working after a racer driver swap.

Or am I wrong about that ?
User avatar
Rinussie
 
Posts: 8
Joined: Wed 7. Nov 2012, 16:05
Location: Spijkenisse Holland
Has thanked: 1 time
Been thanked: 0 time


Return to rFactor & rFactor 2

Who is online

Users browsing this forum: No registered users and 1 guest